Excel Формула поиска по значению

Автор: | 05.12.2023

Как в Microsoft Excel произвести поиск по какому либо значению и подставить результат

Несмотря на все запреты и старания различных «сил», которые стремятся пересадить пользователей на отечественные программные продукты, в первую очередь это касается офисных пакетов, Microsoft Office все еще остается самым популярным не смотря не на что. Измениться эта ситуация думаю не скоро, так как достойных конкурентов просто нет, особенно если рассматривать создание не простых таблиц а сложных, в которых используются сложные формулы и различные функции. Которые позволяют решить не стандартные задачи, одну из таким сегодня и рассмотрим, касается это в первую очередь электронных таблиц.

Заключается она в следующем, есть две таблицы, в которых две колонки содержат одни и те же значения. Необходимо взять значение из первой таблице, найти его во второй и вывести результат обратно в первую таблицу.

Поиск значений в одной таблице и подстановка их в другую в Excel

Для наглядности возьмем вот такую простую таблицу, состоящею из трех колонок «Номер» , «Фамилия» и «Дата рождения» . Во второй таблице есть только Номер, по нему необходимо найти фамилию в первой таблице и подставить её.

Начнем с простого, реализуем сначала вывод фамилии по указанию номера в одной ячейки.

Excel Формула поиска по значению

Для этого необходимо воспользоваться функцией «ВПР» которая может работать с данными из двух таблиц и подтягивать значение из одной в другую. Для решение данной задачи необходимо написать вот такую формулу.

=ВПР(А1;А1:С16;2;0)

ВПР — Сама функция

А1 — Искомое значение

А1:С16 — Таблица по которой будет происходить поиск

2 — Номер колонки со значение (если поставить 3 то будет подставляться дата рождения)

0 — Истина

Как в Microsoft Office произвести поиск по какому либо значению и подставить результат

Теперь если в ячейку «А19» ввести какой либо номер, произойдет поиск его в таблице и подставиться значение, в нашем случае фамилия.

Как в Excel  произвести поиск по какому либо значению и подставить результат

Теперь можно приступить к решению первоначальной задачи. Для того чтобы во вторую таблицу, подставить значение из первой нужно немного изменить функцию.

=ВПР(F2;A1:C16;3;0)

В результате функция ВПР будет брать номер из указанной во второй таблице ячейки, искать его в первой, и возвращать выбранное значение, в нашем случае была указанна колонка «3» т.е. подставляться будет «Дата рождения» .

Как в Excel  произвести поиск по какому либо значению

Реализовать что-то подобное в другом офисном пакет практически не возможно. А это далеко не самая сложная задача. Если Вам известем способ решения подобной задачи в другом офисном пакете, особенно отечественном, обязательно поделитесь им.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

*

code